System Requirements

< appboard | old | installation

Page Contents

1. Supported Operating Systems

Vendor Platform Versions
Sun Microsystems Solaris 8, 9, 10 / Sparc 32 bit
Red Hat / CentOS Linux 8.0, Enterprise ES 2.1, 3, 4, 5, 6
Microsoft Windows Windows XP, 2000, 2003 Server, 2008 Server R2

2. Server Requirements

Component Requirements
Hardware Windows, Linux:
  • 2.0 GHz Processor
  • 2.0 GB RAM

Solaris: 1.0 GHz Processor 2.0 GB RAM

Disk Space Minimum: 1.0 GB*

Recommended: 2.0 GB*

* Note: Additional space may be required for database-related disk space requirements.
Software Java SE Development Kit 6+ (JDK 1.6+)

Web Application Server (Tomcat is default)

Database A specific database installation is not required. Connectivity

from the server to the data sources is needed for presenting data in AppBoard widgets.

3. Default Network Ports

Port (default) Protocol Scope
Web Server 8080 HTTP public
Database (e.g. Postgres) 5432 JBDC private
SSH 22 TCP public

4. Desktop Client Requirements

Vendor Platform Version(s) Plug-In
Microsoft Internet Explorer 6+, 7+, 8.0 Adobe Flash Player 11
Mozilla Firefox 3+ Adobe Flash Player 11


5. Mobile Client Requirements

Device Versions Operating System
Various Various Android
iPhone 4, 4S iOS 4+
iPad 1, 2 iOS 4+

6. Developer Requirements

Software
  • Java SE Development Kit 6+
  • Adobe Flash Builder 4.5.1
  • Adobe Flex SDK 4.5.1
  • Adobe Flex 4.5.1 Data Visualization Components for Flash Builder 4.5.1