System Requirements

< appboard | 2.4


This document provides the system requirements for AppBoard 2.4.

For an enPortal-only deployment, please refer to the enPortal System Requirements page.

Page Contents

1. Server Requirements

1.1. Supported Platforms

The following table lists the operating systems supported by AppBoard, but in general AppBoard is supported on any 32- or 64- bit platform that can run Java 6 or later. AppBoard is also supported on virtualized environments such as VMware.

Vendor Platform Versions
Oracle/Sun Microsystems Solaris 8, 9, 10, 11 - SPARC or x86 / x86_64
Red Hat Enterprise Linux Linux 5.7+, 6 (or equiv for CentOS, Scientific Linux, Oracle Linux, and Amazon Linux)
SUSE Linux Enterprise Server Linux 10, 11
Microsoft Windows Windows 7, 8, Server 2003, Server 2008 R2, Server 2012

1.2. System Requirements

Typical system requirements for an AppBoard-only deployment are listed in the table below.

In addition, you will find examples of system configurations specific to different deployment scenarios such as Dev or Test Lab / Proof of Concept (POC), Network Operations Center (NOC), or Managed Services Providers (MSPs).

Example Deployment Scenarios
Component Minimum
Requirement
(per server)
Dev
or
Test Lab
Internal use
(NOC, SOC, etc)
External use
(MSP customer-facing)
2+ servers in a cluster
CPU Single CPU Single CPU 2+ CPU cores 4-8 CPU cores
Memory 4 GB RAM 4 GB RAM 4-8 GB RAM 16-32 GB RAM
Storage * 1 GB disk 1 GB disk 2 GB disk 2 GB disk
Operating System 32 or 64 bit O/S 32 or 64 bit O/S 64 bit O/S 64 bit O/S
Java Java SE 6 (JRE) installed on AppBoard server (Java SE 7 recommended)
Database ** Recommended: use the embedded H2 database (1)

OPTIONAL: external database; see below (2)

Recommended: use an external, clustered RDBMS (3)

* AppBoard storage requirements are very low as only configuration information and assets are stored locally. However, ultimately this will depend on the implementation and whether any custom solutions are making use of the local filesystem.

** Regarding database requirements:

(1) By default, AppBoard (and enPortal) includes an in-memory H2 database for configuration data to maintain the mappings between users, roles and proxied content. For most deployment scenarios - excluding High Availability (HA), clustered architectures - Edge recommends using this embedded H2 database. This will simplify the deployment and lower hardware cost as the H2 database will be installed on the same physical or logical server as the AppBoard application.
(2) Optionally, if it is desired to use an external database for this configuration data, Edge supports the following databases: Hypersonic, SQLServer, Oracle, SQLAnywhere, PostgreSQL, MySQL and DB2.
(3) For High Availability (HA), clustered architectures, it is required to use an external database on separate hardware to avoid a single point of failure and ideally this database will be installed on an HA database cluster that has a high bandwidth, low latency network connection to the AppBoard servers.

1.2.1. Combined AppBoard & enPortal Deployments

The AppBoard server includes all enPortal components already and it's a matter of licensing that determines whether the enPortal features can be used.

In environments where both AppBoard and enPortal capabilities are being used then the overall system requirements may need to be increased over the example deployment scenarios above. A good starting point would be to increase CPU and Memory by 50%.

1.3. Default Network Ports

Component Port Protocol Scope/Accessibility
Tomcat Web Server 8080 HTTP AppBoard/enPortal server via client host
Tomcat Shutdown Port 8005 N/A localhost
embedded H2 database N/A JDBC/ System File runs in the Tomcat process
(optional - if used) external database Refer to specifications outlined by the vendor of the database of choice.

2. Client Browser Requirements

Vendor Platform Version(s) Minimum Screen Resolution Plug-Ins
Microsoft Internet Explorer 7, 8, 9, 10, 11 1024x768
  • Adobe Flash Player 11+
  • other plug-ins as required by integrated applications
Mozilla Firefox 3.6.28+
Google Chrome 18+

3. Mobile Client Requirements

Vendor Device Operating System Additional Requirements
Vendors distributing Android-based devices

(Samsung, HTC, Google, Sony, etc...)

Various Phones/Tablets Android 2.3.x, 4.x Adobe AIR
Apple iPhone, iPad, iPod Touch iOS 6, iOS 7